
Kepware OPC Server Installation & Activation 

All PanelMate ePro units have the Kepware OPC server preloaded.  If you are a 
PanelMate ePro user, you will need to select and install a Kepware driver.  If you are not 
using a PanelMate unit (or you have an ePro manufactured before April, 2003) you will 
need to install both the Kepware OPC server and driver. 
PanelMate ePro OPC Bundled models (designated by "-OPC" in the catalog number) are 
preconfigured to run any one Kepware driver.  No software activation is required.  If you 
have Kepware software that requires activation, you will receive a 21 digit serial number 
with the Kepware CD that will be used for software licensing.  The software license will 
need to be activated through a software registration process.  Once the process is started 
and the 21 digit serial number is entered, the license will run in a 10-day installation grace 
period.  Note:  It is required that the user keep a record of the 21 digit serial number 
in the event of a hardware or system failure that would require re-installation and re-
activation of the Kepware OPC server.   
Note: Prior to installation and activation on the ePro you should verify that the Protect 
Mode Status of the ePro is set to Normal Mode.  If the ePro is in Protect Mode, changes 
made during installation will be lost at the next ePro boot up.  Refer to the PanelMate ePro 
Users Guide for directions on placing your ePro unit in normal mode. 
If you have an ePro unit that is not an OPC Bundled model then the following steps must 
be taken to install and activate your Kepware OPC server.  PanelMate ePro OPC Bundled 
model users can jump right to the Modifying Kepware Software and Adding a Driver 
section of this document for instructions on how to select and install Kepware OPC drivers. 

Installing and Activating Kepware Software 
1. Access the Kepware installation software found on the Kepware CD to start the 

installation process.  The installation process will create a Kepware Products entry in 
the Start>Programs menu.  This selection can be used for running the installed 
software. 
If you are installing a Kepware OPC server on a PanelMate ePro, go to the installation 
instructions titled Installing Kepware Software on PanelMate ePro from CD or 
Installing Kepware Software on PanelMate ePro from a Network Download in this 
document for more information. 

2. After installation you may configure and test the OPC server/driver in demo mode for 
as long as you desire.  Demo mode allows the server to run for a two-hour period 
before automatically stopping.  It can be re-started for another two-hour period 
indefinitely.  Once you decide to permanently activate the license on your system take 
the next steps to activate the 10-day installation grace period and subsequently license 
the driver for permanent use. 

3. Run the KEPServerEx program (Start>Programs>Kepware 
Products>KEPServerEx>KEPServerEx) and select Purchase a Driver License from 
the Help pull-down menu.  A dialog box will be displayed which lists all unlicensed 
drivers as shown below: 

 



 

4. Select the driver you wish to license and click on the License… button.  A driver-
specific dialog box will open (example shown below) instructing you to enter the serial 
number of the purchased license.  The serial number can be found on the CD 
envelope. 
If you wish to purchase additional serial numbers (licenses) contact your local 
distributor.  Do not contact the Technical Support group to purchase serial numbers. 

 

5. Enter the 21 digit serial number provided on the CD envelope (include the dashes) and 
click OK.  (Note: if you do not have a keyboard connected you may click the Keypad 
button and enter the serial number using your mouse or the touchscreen).  Once the 
serial number has been correctly entered, the licensed driver will now be running in the 
10-day installation grace period.  You will need to perform the Unlock a Licensed 
Driver step within those 10 days or the OPC server will no longer run with that driver.  
The Unlock a Licensed Driver step prepares a driver to be unlocked for full 
unrestricted use and requires that you contact our Technical Support group to receive 
an unlock code.  If you correctly entered a valid serial number/product registration code 
the following dialog box will be displayed which takes you directly to the unlock step by 
clicking on Yes. 

 

6. If you select Yes or subsequently select Help – Unlock a Licensed Driver from the 
Help pull-down menu, the following dialog box will be displayed: 

 



 

7. To obtain the correct password (i.e. unlock code), record the Driver Serial Number (x-
xxxxx-xxxx…) and Computer ID (yyyyyyy-yyy…..) shown in the Unlock dialog box 
above and send that information along with your Name, Company Name, Zip Code, 
Phone Number, and E-Mail address to:  chatechsupport@eaton.com 
You will receive an unlock code via E-mail within one business day of our receiving 
your information.  Once the license activation is complete on the ePro you should place 
it in Protect Mode.  Once the ePro is in Protect Mode and rebooted no changes can be 
made to the C: partition.  This insures reliable performance of the ePro making it 
secure from sudden power loss (eliminates the need for a UPS system), computer 
viruses (eliminates the need for Virus Protection software), and unauthorized program 
installation.  Refer to the PanelMate ePro Users Guide for directions on placing your 
ePro unit in Protect Mode. 

Uninstalling Kepware Software 
Note: Prior to uninstalling Kepware software you should verify that the Protect Mode 
Status of the ePro is set to Normal Mode.  If the ePro is in Protect Mode, changes made 
during uninstalling will be lost at the next ePro boot up.  Refer to the PanelMate ePro 
Users Guide for directions on placing your ePro unit in normal mode. 
To uninstall the Kepware server software you will need to access the Kepware installation 
software.  On the ePro, select Start>Explorer, and browse to the local USB drive or 
network shared drive where the Kepware installation software is located.  Open the 
directory named KEPServerEX_Install, then the Disk1 directory and select the Setup.exe 
application file.  The Kepware Setup Utility Welcome dialog box will appear as shown 
below.  Select Remove to completely remove all installed components.  If you have 
activated any Kepware licenses they will not be removed by this step.  Licenses can be 
recovered by running Setup.exe again and re-installing the OPC server. 
Note: If you have a PanelMate ePro OPC Bundled model (designated by "-OPC" in the 
catalog number) then the Kepware software license remains with the ePro unit and cannot 
be removed or transferred. 
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Transferring or Re-activating a Kepware OPC Server License  
Note: If you have a PanelMate ePro OPC Bundled model (designated by "-OPC" in the 
catalog number) then the Kepware software license is always active and remains with the 
ePro unit.  The license cannot be transferred. All other PanelMate ePro models do not 
support a floppy drive so it is not possible to transfer a Kepware license from an ePro.  
Therefore, the license transfer process cannot be used.  License re-activation is required 
both for moving a license to another ePro and for re-licensing a replacement ePro 
following a hardware failure. 
A Kepware OPC server license can be transferred from one PC to another using the 
Help>Transfer a Driver License… menu selection as long as both PCs have functional 
floppy drives and as long as the hard drive and operating system of the PC containing the 
license is functioning properly.  If one of the PCs does not have a floppy drive or has 
suffered a drive or operating system failure that prevents running of the license transfer, 
then the license activation procedure must be repeated on the new PC.  Note that the 
same serial number used for the initial license activation can be re-used to license the 
same server on the new or replacement PC.  When you e-mail your activation information 
to chatechsupport@eaton.com make a note indicating that this is a re-activation of a 
previously used serial number and describe the circumstances that required the re-
activation. 

Installing Kepware Software on PanelMate ePro From CD 
When installing Kepware OPC servers on a PanelMate ePro care should be taken to install 
only those components of the server required by the application.  Since the ePro has 
limited flash memory resources you should make sure that extraneous installation 
components or unneeded drivers don’t take up space on the drive that could be used by 
other applications.  You will also need to disable writing of the log file to disk once the 
server has been installed.  Prior to installing on the ePro you should verify that the Protect 
Mode Status of the ePro is set to Normal Mode.  If the ePro is in Protect Mode, changes 
made during installation will be lost at the next ePro boot up.  Refer to the PanelMate ePro 
Users Guide for directions on placing your ePro unit in normal mode. 
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The following steps show the correct way to load a Kepware OPC server on the ePro.  
This example will install the ControlLogix Ethernet driver from the Allen Bradley Suite. 
1. On the ePro, select Start>Explorer, and browse to the local USB drive or network 

shared drive where the Kepware installation CD is located.  Open the directory named 
KEPServerEX_Install, then the Disk1 directory and select the Setup.exe application file.  
The Install shield wizard will begin the installation process, a splash screen will be 
drawn then the following dialog box will appear: 

 
2. Click on the Next > button and the license agreement dialog box will appear: 

 

To accept the terms of the license agreement, click on the Yes button.   
The Choose Destination Location dialog box will appear as shown below.  Accept the 
default destination of C:\Program Files\KEPServerEx by clicking on the Next > button. 

 



 

3. The Select Components dialog box will appear as shown below: 

 

Uncheck the selected boxes for Example Source Code and Specifications. 
After the changes the dialog box should appear as shown below: 

 

 



Select the + sign next to Drivers to see the complete list of drivers.  Select the driver or 
drivers that you want to install. 
This example will select the ControlLogix Ethernet driver from within the AB Suite of 
drivers.  The dialog box will appear as shown below: 

 

Click on the Next > button once the drivers have been selected. 
4. The Select Program Folder dialog box will appear.  Accept the default selection of 

Kepware Products\KEPServerEx by once again clicking on the Next > button.  The 
Start Copying Files dialog box will then appear as shown below.  Begin the installation 
of the server and selected drivers by clicking on the Next > button. 

 

5. The Setup Status dialog box will show a progress bar as files are copied.  When 
copying is complete the Installation Wizard Complete dialog box will appear as shown 
below.  You can choose whether or not you wish to view the readme file but leave the 
checkbox checked to automatically launch the server following the installation and then 
click the Finish button. 

 



 

6. Once the Kepserver is opened click on the Tools > Options… menu selection as 
shown below: 

 

This will open the Options dialog box.  Click on the Event Log tab and uncheck the 
Preserve Log on Disk checkbox as shown below and click on Apply or OK to save the 
change. 

 

Installation and setup of the Kepware OPC server on PanelMate ePro is now complete.  
You can proceed to install and activate your Kepware license and configure your OPC 
server project. 

 



Installing Kepware Software on PanelMate ePro From a Network 
Download 
Frequently you may find that a new feature, driver, or bug fix is not included on the original 
Kepware CD that you received from Cutler-Hammer or you need to do a first time install of 
the server from an OPC server installation image that was downloaded from either the 
Kepware or Cutler-Hammer download website.  Kepware’s downloaded installation image 
is a single compressed executable file that is designed to self extract an install image 
directory structure to a temporary location on the hard drive, essentially creating the CD 
image on your hard drive. 
Once that temporary image is created the setup utility is automatically launched and the 
install proceeds identically to the CD install.  Once the installation is completed the install 
image is automatically removed/deleted from the hard drive.  Because this image is 
created in a temporary directory on the computer that runs the downloaded executable and 
because a standard ePro doesn’t have enough free disk (flash) space to extract the CD 
image, you cannot launch the file from the ePro without potentially filling up the flash drive 
and crashing the install program.  To install the downloaded OPC server on the ePro you 
first need to extract the CD image on your PC and then browse to that temporary directory 
from the ePro (or copy the image to a USB drive for subsequent installation). 
If you have WinZip installed on your PC you can extract the downloaded file to a CD image 
in a temporary directory by right clicking on the file and choosing Extract To ….  If you 
don’t have WinZip installed on your PC you can still extract the CD image to a temporary 
directory from the website download.  First open Windows Explorer or My Computer on 
your PC and browse to the directory to which the file was downloaded.  Next, double-click 
on the file kepsspex.exe to start the extraction process.  The Extracting Files dialog box 
will display a progress bar as the CD image is created on your hard drive’s temporary 
directory.  Next the Kepware Setup Utility Welcome dialog box will appear.  Leave the 
dialog box open and switch back to Windows Explorer or My Computer (<ALT> <TAB>) so 
that you can copy the CD image from the temporary directory to another directory on your 
computer.   
Depending on the operating system of your PC the temporary image will be found in 
different directories.  On Windows NT PCs the image will be located under 
C:\Temp\pftxxx.tmp\Disk1 (where xxx is a 1, 2, or 3 digit number or letter that varies from 
installation to installation).  On Windows 2000 and Windows XP PCs the image will be 
located under C:\Documents and Settings\ Username\Local 
Settings\Temp\pftxxx.tmp\ Disk1 (where Username is the name of the user who is 
currently logged on).  Note also that your View tab under Windows Explorer Folder Options 
(Tools>Folder Options menu selection) must be set to show both hidden and system files 
in order to browse to this directory under Windows 2000 or XP.  On Windows 98 machines 
the image will be located under C:\Windows\Temp\pftxxxx.tmp\Disk1.  Copy the entire 
Disk1 directory contents to a shared folder on your PC that the ePro is capable of “seeing” 
on the network.  Alternatively you may copy the contents to an Iomega Zip or PocketZip 
USB drive that can be plugged into the ePro as a removable drive.  Once you have 
completed the copy you can return to the Kepware Setup Utility and click on the Cancel 
button to cancel out of the server installation on your PC. 

 



Prior to installing on the ePro you should verify that the Protect Mode Status is Normal 
Mode.  If the ePro is in Protect Mode, changes made during installation will be lost at the 
next ePro boot up.  Refer to the PanelMate ePro Users Guide for directions on placing 
your ePro unit in Normal Mode.  You may then go to the ePro, open Explorer, and browse 
to the CD install image and run Setup.exe and install the Kepware OPC server in the same 
manner as from an original Kepware CD which is detailed previously in this document. 

Modifying Kepware Software and Adding a Driver 
Note: Prior to modifying the Kepware OPC server to add a feature or a new driver on the 
ePro you should verify that the Protect Mode Status of the ePro is set to Normal Mode.  If 
the ePro is in Protect Mode, changes made during installation will be lost at the next ePro 
boot up.  Refer to the PanelMate ePro Users Guide for directions on placing your ePro unit 
in normal mode. 
To modify the Kepware server software you will need access to the Kepware installation 
software.  On the ePro, select Start>Explorer, and browse to the local USB drive or 
network shared drive where the Kepware installation software is located.  Open the 
directory named KEPServerEX_Install, then the Disk1 directory and select the Setup.exe 
application file.  The Kepware Setup Utility Welcome dialog box will appear as shown 
below. 

 

Select the Modify radio button then click on the Next > button.  The Select Components 
dialog box will be displayed as shown below.  

 



 

Select the + sign next to Drivers to see the complete list of drivers.  Select the driver or 
drivers that you want to install.  This example will select the ControlLogix Ethernet driver 
from within the AB Suite of drivers.  The dialog box will appear as shown below: 

 

Click on the Next > button once the drivers have been selected.  Once the Modifications 
Complete dialog box is closed, the OPC server has been modified. 
Place the ePro unit back into Protect Mode once the modification process is completed.  
Refer to the PanelMate ePro Users Guide, for directions on placing your ePro unit in 
Protect Mode. 

Updating Kepware Software 
From time to time you may wish to update the Kepware OPC server to add a feature, fix a 
bug or update a driver.  Prior to updating the Kepware OPC server on the ePro you should 
verify that the Protect Mode Status is Normal Mode.  If the ePro is in Protect Mode, 
changes made during installation will be lost at the next ePro boot up.  Refer to the 
PanelMate ePro Users Guide, for directions on placing your ePro unit in Normal Mode. 
To update the Kepware server software you will need access to Kepware installation 
software.  On the ePro, select Start>Explorer, and browse to the local USB drive or 

 



 

network shared drive where the Kepware installation software is located.  Open the 
directory named KEPServerEX_Install, then the Disk1 directory and select the Setup.exe 
application file.  The Kepware Setup Utility Welcome dialog box will appear as shown in 
the previous section.  Select the Update radio button then click on the Next > button.  
After the Updates Complete dialog box is closed you have completely updated the current 
server and installed drivers. 
Place the ePro unit back into Protect Mode once the update process is completed.  Refer 
to the PanelMate ePro Users Guide for directions on placing the ePro unit in Protect Mode. 
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